librelist archives

« back to archive

Numerous Strict Mode Errors

Numerous Strict Mode Errors

From:
Richard
Date:
2015-08-14 @ 08:54
I am a new user seeing some confusing behaviour - can anyone explain?

I have installed conkeror from the snapshot archive 
conkeror-a1f7e87.tar.gz which appears to be fairly recent and am running 
with xulrunner.exe v37 (although on another machine I have also tried v40 
with the same results).

I am seeing essentially the same errors as were reported back in March:

http://librelist.com/browser//conkeror/2015/3/21/conkeror-not-loading-at-all/

Lots of 'octal constants are deprecated', 'let blocks are deprecated', 'in
strict mode functions must be top level' etc. (these are showing in the 
jsconsole - I do not yet know how to log these to a file to be pasted 
here.).

What I find confusing is that I inferred from the email trail in March 
that this was fixed many months ago. Why am I seeing this on a recent 
snapshot? Have I done something stupid during installation?

Many thanks, Richard.