librelist archives

« back to archive

[Solved] Stackoverflow and google search keys fall through

[Solved] Stackoverflow and google search keys fall through

From:
Vitalie Spinu
Date:
2015-01-11 @ 19:48
Hi.

After recent changes my keys (g and q) started falling through on
stackoverflow.  An even bigger problem is with the google search
page. The input field swallows all low cap keys (this is older
behavior).

I don't use page modes so I was really unhappy with this issue till I
noticed that conkeror -q doesn't show the problem.

It turned out that the cause is the following line in my .conkerorrc:

  session_pref("general.useragent.compatMode.firefox", true);


I am posting here in case other people have similar problems. I am on
XUL 34.0, linux.


Thanks,

  Vitalie

Re: [conkeror] [Solved] Stackoverflow and google search keys fall through

From:
Scott Jaderholm
Date:
2015-01-12 @ 08:56
From http://conkeror.org/GoogleSearchResults

"A workaround is to go into Google search settings, and turn off
Google Instant predictions (i.e, set it to 'Never show Instant
results.'). "

Scott


On Sun, Jan 11, 2015 at 11:48 AM, Vitalie Spinu <spinuvit@gmail.com> wrote:
>
> Hi.
>
> After recent changes my keys (g and q) started falling through on
> stackoverflow.  An even bigger problem is with the google search
> page. The input field swallows all low cap keys (this is older
> behavior).
>
> I don't use page modes so I was really unhappy with this issue till I
> noticed that conkeror -q doesn't show the problem.
>
> It turned out that the cause is the following line in my .conkerorrc:
>
>   session_pref("general.useragent.compatMode.firefox", true);
>
>
> I am posting here in case other people have similar problems. I am on
> XUL 34.0, linux.
>
>
> Thanks,
>
>   Vitalie
>

Re: [conkeror] [Solved] Stackoverflow and google search keys fall through

From:
Ramon Diaz-Uriarte
Date:
2015-01-28 @ 11:18
Hi Vitalie,

I had the same problem, which was most annoying with g and c, but I did not
have your offending line and, in fact, conkeror -q does not solve the
problem for me. I am running the latest available version of conkeror in
Debian (1.0~~pre-1+git141025-1) which reports to use XULRunner 31.4.0,
Linux.

TAB or ESC do not help either, and using the latest code from github didn't
either (and I just fetched the latest code from git with the same results).

When I started experiencing the problem (late november 2014) I ended up
reverting to conkeror-cc462d40a4715762b09a963656b29a0e076fb4ec.tar.gz, from
October 2014,

(http://repo.or.cz/w/conkeror.git/commit/cc462d40a4715762b09a963656b29a0e076fb4ec),
which used to be, I think, the previous latest Debian version.

It reports itself as Conkeror 1.0pre1 (XULRunner 24.7.0, Linux)

And thinks work fine.


I understand this is not a solution, but I have no idea where the problem
lies, or even if it is a problem in conkeror or a problem with something in
my machines. But this kludge at least works for now.


Best,


R.



On Sun, 11-01-2015, at 20:48, Vitalie Spinu <spinuvit@gmail.com> wrote:
> Hi.
>
> After recent changes my keys (g and q) started falling through on
> stackoverflow.  An even bigger problem is with the google search
> page. The input field swallows all low cap keys (this is older
> behavior).
>
> I don't use page modes so I was really unhappy with this issue till I
> noticed that conkeror -q doesn't show the problem.
>
> It turned out that the cause is the following line in my .conkerorrc:
>
>   session_pref("general.useragent.compatMode.firefox", true);
>
>
> I am posting here in case other people have similar problems. I am on
> XUL 34.0, linux.
>
>
> Thanks,
>
>   Vitalie

-- 
Ramon Diaz-Uriarte
Department of Biochemistry, Lab B-25
Facultad de Medicina
Universidad Autónoma de Madrid 
Arzobispo Morcillo, 4
28029 Madrid
Spain

Phone: +34-91-497-2412

Email: rdiaz02@gmail.com
       ramon.diaz@iib.uam.es

http://ligarto.org/rdiaz

Re: [conkeror] Stackoverflow and google search keys fall through

From:
Vitalie Spinu
Date:
2015-01-28 @ 12:08
Hi Ramon,

I confirm that the problem with stackoverflow is in the latest git. I
sent earlier an mail which didn't get through (attached). Librelist just
keeps bombarding me with confirmation requests without getting my mails
through.

I am just reverting to 5afa62ca586da2 (4 commits behind) and it works as
expected. So recent stackoverflow changes are clearly to blame for this
behavior.

The line

  session_pref("general.useragent.compatMode.firefox", true);

is still the cause of problems with google search page. If I remove it,
letters don't fall through on google page, but "google-search-results"
addon doesn't work anymore :(.


   Vitalie


-----------------------------------------------------------------------------
From: Vitalie Spinu <spinuvit@gmail.com>
Subject: Re: [conkeror] [Solved] Stackoverflow and google search keys fall through
To: Merlin Dou <doumerlin@gmail.com>
Cc: conkeror@librelist.com
Date: Wed, 14 Jan 2015 06:11:24 +0100 (2 weeks, 6 hours, 30 minutes ago)


I have just re-installed my system and the problem started showing
again,  even without conkerorrc.

The recent changes on stackoverflow are clearly to blame. If I revert to

   commit 98e89c7e5ff3a1069a0984338da01273cdb189a2
   Author: Joren Van Onder <joren.vanonder@gmail.com>
   Date:   Fri Oct 17 17:14:41 2014 +0200

all conkeror keys work as expected on stackoverflow.

I don't understand how this could be. Stackoverflow page mode is not
loaded and the recent changes should not have any effect. Am I the only
one who is having this problem?

How can I check if a page mode is loaded from inside conkeror?

Thanks,

  Vitalie

PS: I am starting conkeror with a profile:

  exec ~/bin/xulrunner/xulrunner ~/bin/conkeror/application.ini -P conk "$@"

 >>> Ramon Diaz-Uriarte on Wed, 28 Jan 2015 12:18:08 +0100 wrote:

 > Hi Vitalie,
 > I had the same problem, which was most annoying with g and c, but I did not
 > have your offending line and, in fact, conkeror -q does not solve the
 > problem for me. I am running the latest available version of conkeror in
 > Debian (1.0~~pre-1+git141025-1) which reports to use XULRunner 31.4.0,
 > Linux.

 > TAB or ESC do not help either, and using the latest code from github didn't
 > either (and I just fetched the latest code from git with the same results).

 > When I started experiencing the problem (late november 2014) I ended up
 > reverting to conkeror-cc462d40a4715762b09a963656b29a0e076fb4ec.tar.gz, from
 > October 2014,
 > 
(http://repo.or.cz/w/conkeror.git/commit/cc462d40a4715762b09a963656b29a0e076fb4ec),which
used to be, I think, the previous latest Debian version.

 > It reports itself as Conkeror 1.0pre1 (XULRunner 24.7.0, Linux)

 > And thinks work fine.

 > I understand this is not a solution, but I have no idea where the problem
 > lies, or even if it is a problem in conkeror or a problem with something in
 > my machines. But this kludge at least works for now.

 > Best,

 > R.

 > On Sun, 11-01-2015, at 20:48, Vitalie Spinu <spinuvit@gmail.com> wrote:
 >> Hi.
 >> 
 >> After recent changes my keys (g and q) started falling through on
 >> stackoverflow.  An even bigger problem is with the google search
 >> page. The input field swallows all low cap keys (this is older
 >> behavior).
 >> 
 >> I don't use page modes so I was really unhappy with this issue till I
 >> noticed that conkeror -q doesn't show the problem.
 >> 
 >> It turned out that the cause is the following line in my .conkerorrc:
 >> 
 >> session_pref("general.useragent.compatMode.firefox", true);
 >> 
 >> 
 >> I am posting here in case other people have similar problems. I am on
 >> XUL 34.0, linux.
 >> 
 >> 
 >> Thanks,
 >> 
 >> Vitalie

Re: [conkeror] StackOverflow keys fall through: Disable by default?

From:
Axel Beckert
Date:
2015-01-29 @ 11:16
Hi,

On Wed, Jan 28, 2015 at 01:08:02PM +0100, Vitalie Spinu wrote:
> I am just reverting to 5afa62ca586da2 (4 commits behind) and it works as
> expected. So recent stackoverflow changes are clearly to blame for this
> behavior.

I must admit, I'm not getting used to prefixing commands on
StackExchange sites with C-z. I'm not yet annoyed, but I fear, I'm
getting there.

It seems as if the new StackExchange page-modes are not appreciated by
all StackExchange users -- and probably by noone who just surfs there
because Google pointed him to an answer for his question over there.

So I suggest to disable the StackExchange page mode by default in the
future. They are probably useful for StackExchange power users (who
can still enable them via their conkerorrc), but they clearly aren't
for the occassional user who just surfs by.

		Kind regards, Axel
-- 
/~\  Plain Text Ribbon Campaign                   | Axel Beckert
\ /  Say No to HTML in E-Mail and News            | abe@deuxchevaux.org  (Mail)
 X   See http://www.nonhtmlmail.org/campaign.html | abe@noone.org (Mail+Jabber)
/ \  I love long mails: http://email.is-not-s.ms/ | http://abe.noone.org/ (Web)

Re: [conkeror] StackOverflow keys fall through: Disable by default?

From:
John J. Foerch
Date:
2015-01-29 @ 12:40
On Thu, Jan 29, 2015 at 12:16:35PM +0100, Axel Beckert wrote:
> Hi,
> 
> On Wed, Jan 28, 2015 at 01:08:02PM +0100, Vitalie Spinu wrote:
> > I am just reverting to 5afa62ca586da2 (4 commits behind) and it works as
> > expected. So recent stackoverflow changes are clearly to blame for this
> > behavior.
> 
> I must admit, I'm not getting used to prefixing commands on
> StackExchange sites with C-z. I'm not yet annoyed, but I fear, I'm
> getting there.
> 
> It seems as if the new StackExchange page-modes are not appreciated by
> all StackExchange users -- and probably by noone who just surfs there
> because Google pointed him to an answer for his question over there.
> 
> So I suggest to disable the StackExchange page mode by default in the
> future. They are probably useful for StackExchange power users (who
> can still enable them via their conkerorrc), but they clearly aren't
> for the occassional user who just surfs by.
> 
> 		Kind regards, Axel
> -- 
> /~\  Plain Text Ribbon Campaign                   | Axel Beckert
> \ /  Say No to HTML in E-Mail and News            | abe@deuxchevaux.org  (Mail)
>  X   See http://www.nonhtmlmail.org/campaign.html | abe@noone.org (Mail+Jabber)
> / \  I love long mails: http://email.is-not-s.ms/ | http://abe.noone.org/ (Web)

Sounds like a good idea.

--
John Foerch

Re: [conkeror] StackOverflow keys fall through: Disabled by default from now on

From:
Axel Beckert
Date:
2015-01-29 @ 13:37
Hi,

On Thu, Jan 29, 2015 at 07:40:04AM -0500, John J. Foerch wrote:
> On Thu, Jan 29, 2015 at 12:16:35PM +0100, Axel Beckert wrote:
> > So I suggest to disable the StackExchange page mode by default in the
> > future. They are probably useful for StackExchange power users (who
> > can still enable them via their conkerorrc), but they clearly aren't
> > for the occassional user who just surfs by.
> 
> Sounds like a good idea.

Committed, verified and pushed an according change.

		Kind regards, Axel
-- 
/~\  Plain Text Ribbon Campaign                   | Axel Beckert
\ /  Say No to HTML in E-Mail and News            | abe@deuxchevaux.org  (Mail)
 X   See http://www.nonhtmlmail.org/campaign.html | abe@noone.org (Mail+Jabber)
/ \  I love long mails: http://email.is-not-s.ms/ | http://abe.noone.org/ (Web)

Re: [conkeror] StackOverflow keys fall through: Disabled by default from now on

From:
Ramon Diaz-Uriarte
Date:
2015-01-30 @ 09:46
Thanks. I just tried it, and it works for me too.

Best,


R.


On Thu, 29-01-2015, at 14:37, Axel Beckert <abe@deuxchevaux.org> wrote:
> Hi,
>
> On Thu, Jan 29, 2015 at 07:40:04AM -0500, John J. Foerch wrote:
>> On Thu, Jan 29, 2015 at 12:16:35PM +0100, Axel Beckert wrote:
>> > So I suggest to disable the StackExchange page mode by default in the
>> > future. They are probably useful for StackExchange power users (who
>> > can still enable them via their conkerorrc), but they clearly aren't
>> > for the occassional user who just surfs by.
>> 
>> Sounds like a good idea.
>
> Committed, verified and pushed an according change.
>
> 		Kind regards, Axel

-- 
Ramon Diaz-Uriarte
Department of Biochemistry, Lab B-25
Facultad de Medicina
Universidad Autónoma de Madrid 
Arzobispo Morcillo, 4
28029 Madrid
Spain

Phone: +34-91-497-2412

Email: rdiaz02@gmail.com
       ramon.diaz@iib.uam.es

http://ligarto.org/rdiaz

Re: [conkeror] Stackoverflow and google search keys fall through

From:
Ista Zahn
Date:
2015-01-28 @ 13:06
I've had this problem too, though I've only been using conkeror for a
short time, so I didn't realize it was unexpected. I'm mostly trained
myself to prefix 'C-z' when on a google or stackoverflow page, but it
would of course be nice not to have to do that.

Best,
Ista

On Wed, Jan 28, 2015 at 7:08 AM, Vitalie Spinu <spinuvit@gmail.com> wrote:
>
> Hi Ramon,
>
> I confirm that the problem with stackoverflow is in the latest git. I
> sent earlier an mail which didn't get through (attached). Librelist just
> keeps bombarding me with confirmation requests without getting my mails
> through.
>
> I am just reverting to 5afa62ca586da2 (4 commits behind) and it works as
> expected. So recent stackoverflow changes are clearly to blame for this
> behavior.
>
> The line
>
>   session_pref("general.useragent.compatMode.firefox", true);
>
> is still the cause of problems with google search page. If I remove it,
> letters don't fall through on google page, but "google-search-results"
> addon doesn't work anymore :(.
>
>
>    Vitalie
>
>
> -----------------------------------------------------------------------------
> From: Vitalie Spinu <spinuvit@gmail.com>
> Subject: Re: [conkeror] [Solved] Stackoverflow and google search keys 
fall through
> To: Merlin Dou <doumerlin@gmail.com>
> Cc: conkeror@librelist.com
> Date: Wed, 14 Jan 2015 06:11:24 +0100 (2 weeks, 6 hours, 30 minutes ago)
>
>
> I have just re-installed my system and the problem started showing
> again,  even without conkerorrc.
>
> The recent changes on stackoverflow are clearly to blame. If I revert to
>
>    commit 98e89c7e5ff3a1069a0984338da01273cdb189a2
>    Author: Joren Van Onder <joren.vanonder@gmail.com>
>    Date:   Fri Oct 17 17:14:41 2014 +0200
>
> all conkeror keys work as expected on stackoverflow.
>
> I don't understand how this could be. Stackoverflow page mode is not
> loaded and the recent changes should not have any effect. Am I the only
> one who is having this problem?
>
> How can I check if a page mode is loaded from inside conkeror?
>
> Thanks,
>
>   Vitalie
>
> PS: I am starting conkeror with a profile:
>
>   exec ~/bin/xulrunner/xulrunner ~/bin/conkeror/application.ini -P conk "$@"
>
>  >>> Ramon Diaz-Uriarte on Wed, 28 Jan 2015 12:18:08 +0100 wrote:
>
>  > Hi Vitalie,
>  > I had the same problem, which was most annoying with g and c, but I did not
>  > have your offending line and, in fact, conkeror -q does not solve the
>  > problem for me. I am running the latest available version of conkeror in
>  > Debian (1.0~~pre-1+git141025-1) which reports to use XULRunner 31.4.0,
>  > Linux.
>
>  > TAB or ESC do not help either, and using the latest code from github didn't
>  > either (and I just fetched the latest code from git with the same results).
>
>  > When I started experiencing the problem (late november 2014) I ended up
>  > reverting to conkeror-cc462d40a4715762b09a963656b29a0e076fb4ec.tar.gz, from
>  > October 2014,
>  > 
(http://repo.or.cz/w/conkeror.git/commit/cc462d40a4715762b09a963656b29a0e076fb4ec),which
used to be, I think, the previous latest Debian version.
>
>  > It reports itself as Conkeror 1.0pre1 (XULRunner 24.7.0, Linux)
>
>  > And thinks work fine.
>
>  > I understand this is not a solution, but I have no idea where the problem
>  > lies, or even if it is a problem in conkeror or a problem with something in
>  > my machines. But this kludge at least works for now.
>
>  > Best,
>
>  > R.
>
>  > On Sun, 11-01-2015, at 20:48, Vitalie Spinu <spinuvit@gmail.com> wrote:
>  >> Hi.
>  >>
>  >> After recent changes my keys (g and q) started falling through on
>  >> stackoverflow.  An even bigger problem is with the google search
>  >> page. The input field swallows all low cap keys (this is older
>  >> behavior).
>  >>
>  >> I don't use page modes so I was really unhappy with this issue till I
>  >> noticed that conkeror -q doesn't show the problem.
>  >>
>  >> It turned out that the cause is the following line in my .conkerorrc:
>  >>
>  >> session_pref("general.useragent.compatMode.firefox", true);
>  >>
>  >>
>  >> I am posting here in case other people have similar problems. I am on
>  >> XUL 34.0, linux.
>  >>
>  >>
>  >> Thanks,
>  >>
>  >> Vitalie

Re: [conkeror] Stackoverflow and google search keys fall through

From:
Ramon Diaz-Uriarte
Date:
2015-01-30 @ 09:45
Hi Vitalie,


(Sorry for the delay; swamped by classes)

On Wed, 28-01-2015, at 13:08, Vitalie Spinu <spinuvit@gmail.com> wrote:
> Hi Ramon,
>
> I confirm that the problem with stackoverflow is in the latest git. I
> sent earlier an mail which didn't get through (attached). Librelist just
> keeps bombarding me with confirmation requests without getting my mails
> through.
>
> I am just reverting to 5afa62ca586da2 (4 commits behind) and it works as
> expected. So recent stackoverflow changes are clearly to blame for this
> behavior.

I just tried the newest commit by Axel, and stackoverflow works just fine.


>
> The line
>
>   session_pref("general.useragent.compatMode.firefox", true);
>
> is still the cause of problems with google search page. If I remove it,
> letters don't fall through on google page, but "google-search-results"
> addon doesn't work anymore :(.

With the latest version, I do not have any problems (that I can see) with
google search, but I am not using the google-search-results addon (I
confess I have no idea what it would do, and thus what I am missing, so
I'll have to try it).


R.


>
>
>    Vitalie
>
>
> -----------------------------------------------------------------------------
> From: Vitalie Spinu <spinuvit@gmail.com>
> Subject: Re: [conkeror] [Solved] Stackoverflow and google search keys 
fall through
> To: Merlin Dou <doumerlin@gmail.com>
> Cc: conkeror@librelist.com
> Date: Wed, 14 Jan 2015 06:11:24 +0100 (2 weeks, 6 hours, 30 minutes ago)
>
>
> I have just re-installed my system and the problem started showing
> again,  even without conkerorrc.
>
> The recent changes on stackoverflow are clearly to blame. If I revert to
>
>    commit 98e89c7e5ff3a1069a0984338da01273cdb189a2
>    Author: Joren Van Onder <joren.vanonder@gmail.com>
>    Date:   Fri Oct 17 17:14:41 2014 +0200
>
> all conkeror keys work as expected on stackoverflow.
>
> I don't understand how this could be. Stackoverflow page mode is not
> loaded and the recent changes should not have any effect. Am I the only
> one who is having this problem?
>
> How can I check if a page mode is loaded from inside conkeror?
>
> Thanks,
>
>   Vitalie
>
> PS: I am starting conkeror with a profile:
>
>   exec ~/bin/xulrunner/xulrunner ~/bin/conkeror/application.ini -P conk "$@"
>
>  >>> Ramon Diaz-Uriarte on Wed, 28 Jan 2015 12:18:08 +0100 wrote:
>
>  > Hi Vitalie,
>  > I had the same problem, which was most annoying with g and c, but I did not
>  > have your offending line and, in fact, conkeror -q does not solve the
>  > problem for me. I am running the latest available version of conkeror in
>  > Debian (1.0~~pre-1+git141025-1) which reports to use XULRunner 31.4.0,
>  > Linux.
>
>  > TAB or ESC do not help either, and using the latest code from github didn't
>  > either (and I just fetched the latest code from git with the same results).
>
>  > When I started experiencing the problem (late november 2014) I ended up
>  > reverting to conkeror-cc462d40a4715762b09a963656b29a0e076fb4ec.tar.gz, from
>  > October 2014,
>  > 
(http://repo.or.cz/w/conkeror.git/commit/cc462d40a4715762b09a963656b29a0e076fb4ec),which
used to be, I think, the previous latest Debian version.
>
>  > It reports itself as Conkeror 1.0pre1 (XULRunner 24.7.0, Linux)
>
>  > And thinks work fine.
>
>  > I understand this is not a solution, but I have no idea where the problem
>  > lies, or even if it is a problem in conkeror or a problem with something in
>  > my machines. But this kludge at least works for now.
>
>  > Best,
>
>  > R.
>
>  > On Sun, 11-01-2015, at 20:48, Vitalie Spinu <spinuvit@gmail.com> wrote:
>  >> Hi.
>  >> 
>  >> After recent changes my keys (g and q) started falling through on
>  >> stackoverflow.  An even bigger problem is with the google search
>  >> page. The input field swallows all low cap keys (this is older
>  >> behavior).
>  >> 
>  >> I don't use page modes so I was really unhappy with this issue till I
>  >> noticed that conkeror -q doesn't show the problem.
>  >> 
>  >> It turned out that the cause is the following line in my .conkerorrc:
>  >> 
>  >> session_pref("general.useragent.compatMode.firefox", true);
>  >> 
>  >> 
>  >> I am posting here in case other people have similar problems. I am on
>  >> XUL 34.0, linux.
>  >> 
>  >> 
>  >> Thanks,
>  >> 
>  >> Vitalie

-- 
Ramon Diaz-Uriarte
Department of Biochemistry, Lab B-25
Facultad de Medicina
Universidad Autónoma de Madrid 
Arzobispo Morcillo, 4
28029 Madrid
Spain

Phone: +34-91-497-2412

Email: rdiaz02@gmail.com
       ramon.diaz@iib.uam.es

http://ligarto.org/rdiaz

Re: [conkeror] [Solved] Stackoverflow and google search keys fall through

From:
Merlin Dou
Date:
2015-01-12 @ 01:43
Try ESC.

2015-01-12 3:48 GMT+08:00, Vitalie Spinu <spinuvit@gmail.com>:
>
> Hi.
>
> After recent changes my keys (g and q) started falling through on
> stackoverflow.  An even bigger problem is with the google search
> page. The input field swallows all low cap keys (this is older
> behavior).
>
> I don't use page modes so I was really unhappy with this issue till I
> noticed that conkeror -q doesn't show the problem.
>
> It turned out that the cause is the following line in my .conkerorrc:
>
>   session_pref("general.useragent.compatMode.firefox", true);
>
>
> I am posting here in case other people have similar problems. I am on
> XUL 34.0, linux.
>
>
> Thanks,
>
>   Vitalie
>
>


-- 
Regards,

Merlin

Re: [conkeror] [Solved] Stackoverflow and google search keys fall through

From:
Merlin Dou
Date:
2015-01-12 @ 01:44
Or TAB.

2015-01-12 9:43 GMT+08:00, Merlin Dou <doumerlin@gmail.com>:
> Try ESC.
>
> 2015-01-12 3:48 GMT+08:00, Vitalie Spinu <spinuvit@gmail.com>:
>>
>> Hi.
>>
>> After recent changes my keys (g and q) started falling through on
>> stackoverflow.  An even bigger problem is with the google search
>> page. The input field swallows all low cap keys (this is older
>> behavior).
>>
>> I don't use page modes so I was really unhappy with this issue till I
>> noticed that conkeror -q doesn't show the problem.
>>
>> It turned out that the cause is the following line in my .conkerorrc:
>>
>>   session_pref("general.useragent.compatMode.firefox", true);
>>
>>
>> I am posting here in case other people have similar problems. I am on
>> XUL 34.0, linux.
>>
>>
>> Thanks,
>>
>>   Vitalie
>>
>>
>
>
> --
> Regards,
>
> Merlin
>


-- 
Regards,

Merlin