librelist archives

« back to archive

--git doesn't work

--git doesn't work

From:
Wu Jianfeng
Date:
2013-09-02 @ 09:59
Hello,

I installed the latest blohg by "ip install blohg[git]" as I want to use
the git version.
After installed successfully and run "blohg initrepo --repo-path my_blog
--git",
it prompted "blohg: error: unrecognized arguments: --git".
Is the git support removed? Or did I miss some configuration?

Thanks!

Re: [blohg] --git doesn't work

From:
Rafael Martins
Date:
2013-09-02 @ 14:42
Hello,

please run 'pip freeze' and send me the output.

BR,

On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> Hello,
>
> I installed the latest blohg by "ip install blohg[git]" as I want to use the
> git version.
> After installed successfully and run "blohg initrepo --repo-path my_blog
> --git",
> it prompted "blohg: error: unrecognized arguments: --git".
> Is the git support removed? Or did I miss some configuration?
>
> Thanks!



-- 
Rafael Goncalves Martins
http://rafaelmartins.eng.br/

Re: [blohg] --git doesn't work

From:
Wu Jianfeng
Date:
2013-09-03 @ 02:10
here it is
----------------------------------------------------------------
Babel==1.3
Cheetah==2.4.4
Flask==0.10.1
Flask-Babel==0.9
Flask-Script==0.6.2
Frozen-Flask==0.11
Jinja2==2.7.1
Landscape-Client==12.12
M2Crypto==0.21.1
MarkupSafe==0.18
PAM==0.4.2
PyYAML==3.10
Pygments==1.6
Twisted-Core==12.3.0
Twisted-Names==12.3.0
Twisted-Web==12.3.0
Werkzeug==0.9.4
apt-xapian-index==0.45
argparse==1.2.1
blinker==1.3
blohg==0.12
boto==2.3.0
chardet==2.0.1
cloud-init==0.7.2
configobj==4.7.2
distribute==0.6.34
distro-info==0.10
docutils==0.10
euca2ools==2.1.1
itsdangerous==0.23
mercurial==2.7
oauth==1.0.1
paramiko==1.7.7.1
prettytable==0.6.1
pyOpenSSL==0.13
pycrypto==2.6
pycurl==7.19.0
pygit2==0.19.0
pygobject==3.8.0
pyserial==2.6
python-apt==0.8.8ubuntu6
python-debian==0.1.21-nmu2ubuntu1
pytz==2013b
requests==1.1.0
six==1.2.0
speaklater==1.3
ssh-import-id==3.14
urllib3==1.5
wsgiref==0.1.2
zope.interface==4.0.5


On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins <rafael@rafaelmartins.eng.br
> wrote:

> Hello,
>
> please run 'pip freeze' and send me the output.
>
> BR,
>
> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> > Hello,
> >
> > I installed the latest blohg by "ip install blohg[git]" as I want to use
> the
> > git version.
> > After installed successfully and run "blohg initrepo --repo-path my_blog
> > --git",
> > it prompted "blohg: error: unrecognized arguments: --git".
> > Is the git support removed? Or did I miss some configuration?
> >
> > Thanks!
>
>
>
> --
> Rafael Goncalves Martins
> http://rafaelmartins.eng.br/
>

Re: [blohg] --git doesn't work

From:
Rafael Martins
Date:
2013-09-03 @ 02:24
this is weird. you have the correct libs, and the command you pasted
on your first message works fine for me :(

please open the python shell and type:

import blohg.vcs_backends.git

it shouldn't return any error or message.

On Mon, Sep 2, 2013 at 11:10 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> here it is
> ----------------------------------------------------------------
> Babel==1.3
> Cheetah==2.4.4
> Flask==0.10.1
> Flask-Babel==0.9
> Flask-Script==0.6.2
> Frozen-Flask==0.11
> Jinja2==2.7.1
> Landscape-Client==12.12
> M2Crypto==0.21.1
> MarkupSafe==0.18
> PAM==0.4.2
> PyYAML==3.10
> Pygments==1.6
> Twisted-Core==12.3.0
> Twisted-Names==12.3.0
> Twisted-Web==12.3.0
> Werkzeug==0.9.4
> apt-xapian-index==0.45
> argparse==1.2.1
> blinker==1.3
> blohg==0.12
> boto==2.3.0
> chardet==2.0.1
> cloud-init==0.7.2
> configobj==4.7.2
> distribute==0.6.34
> distro-info==0.10
> docutils==0.10
> euca2ools==2.1.1
> itsdangerous==0.23
> mercurial==2.7
> oauth==1.0.1
> paramiko==1.7.7.1
> prettytable==0.6.1
> pyOpenSSL==0.13
> pycrypto==2.6
> pycurl==7.19.0
> pygit2==0.19.0
> pygobject==3.8.0
> pyserial==2.6
> python-apt==0.8.8ubuntu6
> python-debian==0.1.21-nmu2ubuntu1
> pytz==2013b
> requests==1.1.0
> six==1.2.0
> speaklater==1.3
> ssh-import-id==3.14
> urllib3==1.5
> wsgiref==0.1.2
> zope.interface==4.0.5
>
>
> On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins
> <rafael@rafaelmartins.eng.br> wrote:
>>
>> Hello,
>>
>> please run 'pip freeze' and send me the output.
>>
>> BR,
>>
>> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com> wrote:
>> > Hello,
>> >
>> > I installed the latest blohg by "ip install blohg[git]" as I want to use
>> > the
>> > git version.
>> > After installed successfully and run "blohg initrepo --repo-path my_blog
>> > --git",
>> > it prompted "blohg: error: unrecognized arguments: --git".
>> > Is the git support removed? Or did I miss some configuration?
>> >
>> > Thanks!
>>
>>
>>
>> --
>> Rafael Goncalves Martins
>> http://rafaelmartins.eng.br/
>
>



-- 
Rafael Goncalves Martins
http://rafaelmartins.eng.br/

Re: [blohg] --git doesn't work

From:
Wu Jianfeng
Date:
2013-09-03 @ 02:46
the import returns no error :(

the "blohg -h" output:

------------------------------------------------------------------------------------------------------
usage: blohg [-h] [--repo-path REPO_PATH] [-e] {initrepo,freeze,runserver}
...
positional arguments:
  {initrepo,freeze,runserver}
    initrepo            initialize a blohg repo, using the default template.
    freeze              freeze the blog into a set of static files.
    runserver           runs the blohg local server.

optional arguments:
  -h, --help            show this help message and exit
  --repo-path REPO_PATH
                        Repository path
  -e, --disable-embedded-extensions
                        disable the loading of extensions from the mercurial
                        repository

------------------------------------------------------------------------------------------------------
there's no "--git" option of the help message.
did I install a wrong version (0.12)?


On Tue, Sep 3, 2013 at 10:24 AM, Rafael Martins <rafael@rafaelmartins.eng.br
> wrote:

> this is weird. you have the correct libs, and the command you pasted
> on your first message works fine for me :(
>
> please open the python shell and type:
>
> import blohg.vcs_backends.git
>
> it shouldn't return any error or message.
>
> On Mon, Sep 2, 2013 at 11:10 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> > here it is
> > ----------------------------------------------------------------
> > Babel==1.3
> > Cheetah==2.4.4
> > Flask==0.10.1
> > Flask-Babel==0.9
> > Flask-Script==0.6.2
> > Frozen-Flask==0.11
> > Jinja2==2.7.1
> > Landscape-Client==12.12
> > M2Crypto==0.21.1
> > MarkupSafe==0.18
> > PAM==0.4.2
> > PyYAML==3.10
> > Pygments==1.6
> > Twisted-Core==12.3.0
> > Twisted-Names==12.3.0
> > Twisted-Web==12.3.0
> > Werkzeug==0.9.4
> > apt-xapian-index==0.45
> > argparse==1.2.1
> > blinker==1.3
> > blohg==0.12
> > boto==2.3.0
> > chardet==2.0.1
> > cloud-init==0.7.2
> > configobj==4.7.2
> > distribute==0.6.34
> > distro-info==0.10
> > docutils==0.10
> > euca2ools==2.1.1
> > itsdangerous==0.23
> > mercurial==2.7
> > oauth==1.0.1
> > paramiko==1.7.7.1
> > prettytable==0.6.1
> > pyOpenSSL==0.13
> > pycrypto==2.6
> > pycurl==7.19.0
> > pygit2==0.19.0
> > pygobject==3.8.0
> > pyserial==2.6
> > python-apt==0.8.8ubuntu6
> > python-debian==0.1.21-nmu2ubuntu1
> > pytz==2013b
> > requests==1.1.0
> > six==1.2.0
> > speaklater==1.3
> > ssh-import-id==3.14
> > urllib3==1.5
> > wsgiref==0.1.2
> > zope.interface==4.0.5
> >
> >
> > On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins
> > <rafael@rafaelmartins.eng.br> wrote:
> >>
> >> Hello,
> >>
> >> please run 'pip freeze' and send me the output.
> >>
> >> BR,
> >>
> >> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> >> > Hello,
> >> >
> >> > I installed the latest blohg by "ip install blohg[git]" as I want to
> use
> >> > the
> >> > git version.
> >> > After installed successfully and run "blohg initrepo --repo-path
> my_blog
> >> > --git",
> >> > it prompted "blohg: error: unrecognized arguments: --git".
> >> > Is the git support removed? Or did I miss some configuration?
> >> >
> >> > Thanks!
> >>
> >>
> >>
> >> --
> >> Rafael Goncalves Martins
> >> http://rafaelmartins.eng.br/
> >
> >
>
>
>
> --
> Rafael Goncalves Martins
> http://rafaelmartins.eng.br/
>

Re: [blohg] --git doesn't work

From:
Rafael Martins
Date:
2013-09-03 @ 02:56
--git just works for 'blohg initrepo', so 'blohg initrepo -h' should
list --git option.

On Mon, Sep 2, 2013 at 11:46 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> the import returns no error :(
>
> the "blohg -h" output:
> 
------------------------------------------------------------------------------------------------------
> usage: blohg [-h] [--repo-path REPO_PATH] [-e] {initrepo,freeze,runserver}
> ...
> positional arguments:
>   {initrepo,freeze,runserver}
>     initrepo            initialize a blohg repo, using the default template.
>     freeze              freeze the blog into a set of static files.
>     runserver           runs the blohg local server.
>
> optional arguments:
>   -h, --help            show this help message and exit
>   --repo-path REPO_PATH
>                         Repository path
>   -e, --disable-embedded-extensions
>                         disable the loading of extensions from the mercurial
>                         repository
> 
------------------------------------------------------------------------------------------------------
> there's no "--git" option of the help message.
> did I install a wrong version (0.12)?
>
>
> On Tue, Sep 3, 2013 at 10:24 AM, Rafael Martins
> <rafael@rafaelmartins.eng.br> wrote:
>>
>> this is weird. you have the correct libs, and the command you pasted
>> on your first message works fine for me :(
>>
>> please open the python shell and type:
>>
>> import blohg.vcs_backends.git
>>
>> it shouldn't return any error or message.
>>
>> On Mon, Sep 2, 2013 at 11:10 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
>> > here it is
>> > ----------------------------------------------------------------
>> > Babel==1.3
>> > Cheetah==2.4.4
>> > Flask==0.10.1
>> > Flask-Babel==0.9
>> > Flask-Script==0.6.2
>> > Frozen-Flask==0.11
>> > Jinja2==2.7.1
>> > Landscape-Client==12.12
>> > M2Crypto==0.21.1
>> > MarkupSafe==0.18
>> > PAM==0.4.2
>> > PyYAML==3.10
>> > Pygments==1.6
>> > Twisted-Core==12.3.0
>> > Twisted-Names==12.3.0
>> > Twisted-Web==12.3.0
>> > Werkzeug==0.9.4
>> > apt-xapian-index==0.45
>> > argparse==1.2.1
>> > blinker==1.3
>> > blohg==0.12
>> > boto==2.3.0
>> > chardet==2.0.1
>> > cloud-init==0.7.2
>> > configobj==4.7.2
>> > distribute==0.6.34
>> > distro-info==0.10
>> > docutils==0.10
>> > euca2ools==2.1.1
>> > itsdangerous==0.23
>> > mercurial==2.7
>> > oauth==1.0.1
>> > paramiko==1.7.7.1
>> > prettytable==0.6.1
>> > pyOpenSSL==0.13
>> > pycrypto==2.6
>> > pycurl==7.19.0
>> > pygit2==0.19.0
>> > pygobject==3.8.0
>> > pyserial==2.6
>> > python-apt==0.8.8ubuntu6
>> > python-debian==0.1.21-nmu2ubuntu1
>> > pytz==2013b
>> > requests==1.1.0
>> > six==1.2.0
>> > speaklater==1.3
>> > ssh-import-id==3.14
>> > urllib3==1.5
>> > wsgiref==0.1.2
>> > zope.interface==4.0.5
>> >
>> >
>> > On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins
>> > <rafael@rafaelmartins.eng.br> wrote:
>> >>
>> >> Hello,
>> >>
>> >> please run 'pip freeze' and send me the output.
>> >>
>> >> BR,
>> >>
>> >> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com> wrote:
>> >> > Hello,
>> >> >
>> >> > I installed the latest blohg by "ip install blohg[git]" as I want to
>> >> > use
>> >> > the
>> >> > git version.
>> >> > After installed successfully and run "blohg initrepo --repo-path
>> >> > my_blog
>> >> > --git",
>> >> > it prompted "blohg: error: unrecognized arguments: --git".
>> >> > Is the git support removed? Or did I miss some configuration?
>> >> >
>> >> > Thanks!
>> >>
>> >>
>> >>
>> >> --
>> >> Rafael Goncalves Martins
>> >> http://rafaelmartins.eng.br/
>> >
>> >
>>
>>
>>
>> --
>> Rafael Goncalves Martins
>> http://rafaelmartins.eng.br/
>
>



-- 
Rafael Goncalves Martins
http://rafaelmartins.eng.br/

Re: [blohg] --git doesn't work

From:
Wu Jianfeng
Date:
2013-09-03 @ 02:59
hi,

it works after i uninstalled blohg, cleaned pip cache of blohg, and
reinstall it.
i guess i installed a wrong version yesterday before you announced the 0.12
release today.


On Tue, Sep 3, 2013 at 10:56 AM, Rafael Martins <rafael@rafaelmartins.eng.br
> wrote:

> --git just works for 'blohg initrepo', so 'blohg initrepo -h' should
> list --git option.
>
> On Mon, Sep 2, 2013 at 11:46 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> > the import returns no error :(
> >
> > the "blohg -h" output:
> >
> 
------------------------------------------------------------------------------------------------------
> > usage: blohg [-h] [--repo-path REPO_PATH] [-e]
> {initrepo,freeze,runserver}
> > ...
> > positional arguments:
> >   {initrepo,freeze,runserver}
> >     initrepo            initialize a blohg repo, using the default
> template.
> >     freeze              freeze the blog into a set of static files.
> >     runserver           runs the blohg local server.
> >
> > optional arguments:
> >   -h, --help            show this help message and exit
> >   --repo-path REPO_PATH
> >                         Repository path
> >   -e, --disable-embedded-extensions
> >                         disable the loading of extensions from the
> mercurial
> >                         repository
> >
> 
------------------------------------------------------------------------------------------------------
> > there's no "--git" option of the help message.
> > did I install a wrong version (0.12)?
> >
> >
> > On Tue, Sep 3, 2013 at 10:24 AM, Rafael Martins
> > <rafael@rafaelmartins.eng.br> wrote:
> >>
> >> this is weird. you have the correct libs, and the command you pasted
> >> on your first message works fine for me :(
> >>
> >> please open the python shell and type:
> >>
> >> import blohg.vcs_backends.git
> >>
> >> it shouldn't return any error or message.
> >>
> >> On Mon, Sep 2, 2013 at 11:10 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> >> > here it is
> >> > ----------------------------------------------------------------
> >> > Babel==1.3
> >> > Cheetah==2.4.4
> >> > Flask==0.10.1
> >> > Flask-Babel==0.9
> >> > Flask-Script==0.6.2
> >> > Frozen-Flask==0.11
> >> > Jinja2==2.7.1
> >> > Landscape-Client==12.12
> >> > M2Crypto==0.21.1
> >> > MarkupSafe==0.18
> >> > PAM==0.4.2
> >> > PyYAML==3.10
> >> > Pygments==1.6
> >> > Twisted-Core==12.3.0
> >> > Twisted-Names==12.3.0
> >> > Twisted-Web==12.3.0
> >> > Werkzeug==0.9.4
> >> > apt-xapian-index==0.45
> >> > argparse==1.2.1
> >> > blinker==1.3
> >> > blohg==0.12
> >> > boto==2.3.0
> >> > chardet==2.0.1
> >> > cloud-init==0.7.2
> >> > configobj==4.7.2
> >> > distribute==0.6.34
> >> > distro-info==0.10
> >> > docutils==0.10
> >> > euca2ools==2.1.1
> >> > itsdangerous==0.23
> >> > mercurial==2.7
> >> > oauth==1.0.1
> >> > paramiko==1.7.7.1
> >> > prettytable==0.6.1
> >> > pyOpenSSL==0.13
> >> > pycrypto==2.6
> >> > pycurl==7.19.0
> >> > pygit2==0.19.0
> >> > pygobject==3.8.0
> >> > pyserial==2.6
> >> > python-apt==0.8.8ubuntu6
> >> > python-debian==0.1.21-nmu2ubuntu1
> >> > pytz==2013b
> >> > requests==1.1.0
> >> > six==1.2.0
> >> > speaklater==1.3
> >> > ssh-import-id==3.14
> >> > urllib3==1.5
> >> > wsgiref==0.1.2
> >> > zope.interface==4.0.5
> >> >
> >> >
> >> > On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins
> >> > <rafael@rafaelmartins.eng.br> wrote:
> >> >>
> >> >> Hello,
> >> >>
> >> >> please run 'pip freeze' and send me the output.
> >> >>
> >> >> BR,
> >> >>
> >> >> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com>
> wrote:
> >> >> > Hello,
> >> >> >
> >> >> > I installed the latest blohg by "ip install blohg[git]" as I want
> to
> >> >> > use
> >> >> > the
> >> >> > git version.
> >> >> > After installed successfully and run "blohg initrepo --repo-path
> >> >> > my_blog
> >> >> > --git",
> >> >> > it prompted "blohg: error: unrecognized arguments: --git".
> >> >> > Is the git support removed? Or did I miss some configuration?
> >> >> >
> >> >> > Thanks!
> >> >>
> >> >>
> >> >>
> >> >> --
> >> >> Rafael Goncalves Martins
> >> >> http://rafaelmartins.eng.br/
> >> >
> >> >
> >>
> >>
> >>
> >> --
> >> Rafael Goncalves Martins
> >> http://rafaelmartins.eng.br/
> >
> >
>
>
>
> --
> Rafael Goncalves Martins
> http://rafaelmartins.eng.br/
>

Re: [blohg] --git doesn't work

From:
Rafael Martins
Date:
2013-09-03 @ 03:01
hehe. yes. I did at least 2 wrong releases last night, but wasn't
expecting people to actively watch pypi and get it before the
announcement.

I'm glad that it works for you now, and thanks for using blohg! :)

On Mon, Sep 2, 2013 at 11:59 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> hi,
>
> it works after i uninstalled blohg, cleaned pip cache of blohg, and
> reinstall it.
> i guess i installed a wrong version yesterday before you announced the 0.12
> release today.
>
>
> On Tue, Sep 3, 2013 at 10:56 AM, Rafael Martins
> <rafael@rafaelmartins.eng.br> wrote:
>>
>> --git just works for 'blohg initrepo', so 'blohg initrepo -h' should
>> list --git option.
>>
>> On Mon, Sep 2, 2013 at 11:46 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
>> > the import returns no error :(
>> >
>> > the "blohg -h" output:
>> >
>> > 
------------------------------------------------------------------------------------------------------
>> > usage: blohg [-h] [--repo-path REPO_PATH] [-e]
>> > {initrepo,freeze,runserver}
>> > ...
>> > positional arguments:
>> >   {initrepo,freeze,runserver}
>> >     initrepo            initialize a blohg repo, using the default
>> > template.
>> >     freeze              freeze the blog into a set of static files.
>> >     runserver           runs the blohg local server.
>> >
>> > optional arguments:
>> >   -h, --help            show this help message and exit
>> >   --repo-path REPO_PATH
>> >                         Repository path
>> >   -e, --disable-embedded-extensions
>> >                         disable the loading of extensions from the
>> > mercurial
>> >                         repository
>> >
>> > 
------------------------------------------------------------------------------------------------------
>> > there's no "--git" option of the help message.
>> > did I install a wrong version (0.12)?
>> >
>> >
>> > On Tue, Sep 3, 2013 at 10:24 AM, Rafael Martins
>> > <rafael@rafaelmartins.eng.br> wrote:
>> >>
>> >> this is weird. you have the correct libs, and the command you pasted
>> >> on your first message works fine for me :(
>> >>
>> >> please open the python shell and type:
>> >>
>> >> import blohg.vcs_backends.git
>> >>
>> >> it shouldn't return any error or message.
>> >>
>> >> On Mon, Sep 2, 2013 at 11:10 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
>> >> > here it is
>> >> > ----------------------------------------------------------------
>> >> > Babel==1.3
>> >> > Cheetah==2.4.4
>> >> > Flask==0.10.1
>> >> > Flask-Babel==0.9
>> >> > Flask-Script==0.6.2
>> >> > Frozen-Flask==0.11
>> >> > Jinja2==2.7.1
>> >> > Landscape-Client==12.12
>> >> > M2Crypto==0.21.1
>> >> > MarkupSafe==0.18
>> >> > PAM==0.4.2
>> >> > PyYAML==3.10
>> >> > Pygments==1.6
>> >> > Twisted-Core==12.3.0
>> >> > Twisted-Names==12.3.0
>> >> > Twisted-Web==12.3.0
>> >> > Werkzeug==0.9.4
>> >> > apt-xapian-index==0.45
>> >> > argparse==1.2.1
>> >> > blinker==1.3
>> >> > blohg==0.12
>> >> > boto==2.3.0
>> >> > chardet==2.0.1
>> >> > cloud-init==0.7.2
>> >> > configobj==4.7.2
>> >> > distribute==0.6.34
>> >> > distro-info==0.10
>> >> > docutils==0.10
>> >> > euca2ools==2.1.1
>> >> > itsdangerous==0.23
>> >> > mercurial==2.7
>> >> > oauth==1.0.1
>> >> > paramiko==1.7.7.1
>> >> > prettytable==0.6.1
>> >> > pyOpenSSL==0.13
>> >> > pycrypto==2.6
>> >> > pycurl==7.19.0
>> >> > pygit2==0.19.0
>> >> > pygobject==3.8.0
>> >> > pyserial==2.6
>> >> > python-apt==0.8.8ubuntu6
>> >> > python-debian==0.1.21-nmu2ubuntu1
>> >> > pytz==2013b
>> >> > requests==1.1.0
>> >> > six==1.2.0
>> >> > speaklater==1.3
>> >> > ssh-import-id==3.14
>> >> > urllib3==1.5
>> >> > wsgiref==0.1.2
>> >> > zope.interface==4.0.5
>> >> >
>> >> >
>> >> > On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins
>> >> > <rafael@rafaelmartins.eng.br> wrote:
>> >> >>
>> >> >> Hello,
>> >> >>
>> >> >> please run 'pip freeze' and send me the output.
>> >> >>
>> >> >> BR,
>> >> >>
>> >> >> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com>
>> >> >> wrote:
>> >> >> > Hello,
>> >> >> >
>> >> >> > I installed the latest blohg by "ip install blohg[git]" as I want
>> >> >> > to
>> >> >> > use
>> >> >> > the
>> >> >> > git version.
>> >> >> > After installed successfully and run "blohg initrepo --repo-path
>> >> >> > my_blog
>> >> >> > --git",
>> >> >> > it prompted "blohg: error: unrecognized arguments: --git".
>> >> >> > Is the git support removed? Or did I miss some configuration?
>> >> >> >
>> >> >> > Thanks!
>> >> >>
>> >> >>
>> >> >>
>> >> >> --
>> >> >> Rafael Goncalves Martins
>> >> >> http://rafaelmartins.eng.br/
>> >> >
>> >> >
>> >>
>> >>
>> >>
>> >> --
>> >> Rafael Goncalves Martins
>> >> http://rafaelmartins.eng.br/
>> >
>> >
>>
>>
>>
>> --
>> Rafael Goncalves Martins
>> http://rafaelmartins.eng.br/
>
>



-- 
Rafael Goncalves Martins
http://rafaelmartins.eng.br/

Re: [blohg] --git doesn't work

From:
Wu Jianfeng
Date:
2013-09-03 @ 03:18
i haven't used it yet, but it seems good, i'd like to try.
keep up the good work!


On Tue, Sep 3, 2013 at 11:01 AM, Rafael Martins <rafael@rafaelmartins.eng.br
> wrote:

> hehe. yes. I did at least 2 wrong releases last night, but wasn't
> expecting people to actively watch pypi and get it before the
> announcement.
>
> I'm glad that it works for you now, and thanks for using blohg! :)
>
> On Mon, Sep 2, 2013 at 11:59 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> > hi,
> >
> > it works after i uninstalled blohg, cleaned pip cache of blohg, and
> > reinstall it.
> > i guess i installed a wrong version yesterday before you announced the
> 0.12
> > release today.
> >
> >
> > On Tue, Sep 3, 2013 at 10:56 AM, Rafael Martins
> > <rafael@rafaelmartins.eng.br> wrote:
> >>
> >> --git just works for 'blohg initrepo', so 'blohg initrepo -h' should
> >> list --git option.
> >>
> >> On Mon, Sep 2, 2013 at 11:46 PM, Wu Jianfeng <wuasiam@gmail.com> wrote:
> >> > the import returns no error :(
> >> >
> >> > the "blohg -h" output:
> >> >
> >> >
> 
------------------------------------------------------------------------------------------------------
> >> > usage: blohg [-h] [--repo-path REPO_PATH] [-e]
> >> > {initrepo,freeze,runserver}
> >> > ...
> >> > positional arguments:
> >> >   {initrepo,freeze,runserver}
> >> >     initrepo            initialize a blohg repo, using the default
> >> > template.
> >> >     freeze              freeze the blog into a set of static files.
> >> >     runserver           runs the blohg local server.
> >> >
> >> > optional arguments:
> >> >   -h, --help            show this help message and exit
> >> >   --repo-path REPO_PATH
> >> >                         Repository path
> >> >   -e, --disable-embedded-extensions
> >> >                         disable the loading of extensions from the
> >> > mercurial
> >> >                         repository
> >> >
> >> >
> 
------------------------------------------------------------------------------------------------------
> >> > there's no "--git" option of the help message.
> >> > did I install a wrong version (0.12)?
> >> >
> >> >
> >> > On Tue, Sep 3, 2013 at 10:24 AM, Rafael Martins
> >> > <rafael@rafaelmartins.eng.br> wrote:
> >> >>
> >> >> this is weird. you have the correct libs, and the command you pasted
> >> >> on your first message works fine for me :(
> >> >>
> >> >> please open the python shell and type:
> >> >>
> >> >> import blohg.vcs_backends.git
> >> >>
> >> >> it shouldn't return any error or message.
> >> >>
> >> >> On Mon, Sep 2, 2013 at 11:10 PM, Wu Jianfeng <wuasiam@gmail.com>
> wrote:
> >> >> > here it is
> >> >> > ----------------------------------------------------------------
> >> >> > Babel==1.3
> >> >> > Cheetah==2.4.4
> >> >> > Flask==0.10.1
> >> >> > Flask-Babel==0.9
> >> >> > Flask-Script==0.6.2
> >> >> > Frozen-Flask==0.11
> >> >> > Jinja2==2.7.1
> >> >> > Landscape-Client==12.12
> >> >> > M2Crypto==0.21.1
> >> >> > MarkupSafe==0.18
> >> >> > PAM==0.4.2
> >> >> > PyYAML==3.10
> >> >> > Pygments==1.6
> >> >> > Twisted-Core==12.3.0
> >> >> > Twisted-Names==12.3.0
> >> >> > Twisted-Web==12.3.0
> >> >> > Werkzeug==0.9.4
> >> >> > apt-xapian-index==0.45
> >> >> > argparse==1.2.1
> >> >> > blinker==1.3
> >> >> > blohg==0.12
> >> >> > boto==2.3.0
> >> >> > chardet==2.0.1
> >> >> > cloud-init==0.7.2
> >> >> > configobj==4.7.2
> >> >> > distribute==0.6.34
> >> >> > distro-info==0.10
> >> >> > docutils==0.10
> >> >> > euca2ools==2.1.1
> >> >> > itsdangerous==0.23
> >> >> > mercurial==2.7
> >> >> > oauth==1.0.1
> >> >> > paramiko==1.7.7.1
> >> >> > prettytable==0.6.1
> >> >> > pyOpenSSL==0.13
> >> >> > pycrypto==2.6
> >> >> > pycurl==7.19.0
> >> >> > pygit2==0.19.0
> >> >> > pygobject==3.8.0
> >> >> > pyserial==2.6
> >> >> > python-apt==0.8.8ubuntu6
> >> >> > python-debian==0.1.21-nmu2ubuntu1
> >> >> > pytz==2013b
> >> >> > requests==1.1.0
> >> >> > six==1.2.0
> >> >> > speaklater==1.3
> >> >> > ssh-import-id==3.14
> >> >> > urllib3==1.5
> >> >> > wsgiref==0.1.2
> >> >> > zope.interface==4.0.5
> >> >> >
> >> >> >
> >> >> > On Mon, Sep 2, 2013 at 10:42 PM, Rafael Martins
> >> >> > <rafael@rafaelmartins.eng.br> wrote:
> >> >> >>
> >> >> >> Hello,
> >> >> >>
> >> >> >> please run 'pip freeze' and send me the output.
> >> >> >>
> >> >> >> BR,
> >> >> >>
> >> >> >> On Mon, Sep 2, 2013 at 6:59 AM, Wu Jianfeng <wuasiam@gmail.com>
> >> >> >> wrote:
> >> >> >> > Hello,
> >> >> >> >
> >> >> >> > I installed the latest blohg by "ip install blohg[git]" as I
> want
> >> >> >> > to
> >> >> >> > use
> >> >> >> > the
> >> >> >> > git version.
> >> >> >> > After installed successfully and run "blohg initrepo --repo-path
> >> >> >> > my_blog
> >> >> >> > --git",
> >> >> >> > it prompted "blohg: error: unrecognized arguments: --git".
> >> >> >> > Is the git support removed? Or did I miss some configuration?
> >> >> >> >
> >> >> >> > Thanks!
> >> >> >>
> >> >> >>
> >> >> >>
> >> >> >> --
> >> >> >> Rafael Goncalves Martins
> >> >> >> http://rafaelmartins.eng.br/
> >> >> >
> >> >> >
> >> >>
> >> >>
> >> >>
> >> >> --
> >> >> Rafael Goncalves Martins
> >> >> http://rafaelmartins.eng.br/
> >> >
> >> >
> >>
> >>
> >>
> >> --
> >> Rafael Goncalves Martins
> >> http://rafaelmartins.eng.br/
> >
> >
>
>
>
> --
> Rafael Goncalves Martins
> http://rafaelmartins.eng.br/
>